dexter1 - 2 months ago

Trying to install it in local, with Windows 10, composer and laravel installed, I get the following error in the console, why can it be? C:\xampp\htdocs>composer create-project pyrocms/pyrocms Installing pyrocms/pyrocms (v3.6.4)

  • Installing pyrocms/pyrocms (v3.6.4): Loading from cache Created project in C:\xampp\htdocs\pyrocms Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

    Problem 1

    • anomaly/streams-platform v1.5.0 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.1 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.10 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.11 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.12 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.13 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.14 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.15 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.16 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.17 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.18 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.19 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.2 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.20 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.21 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.22 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.23 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.24 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.25 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.26 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.27 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.28 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.29 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.3 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.30 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.31 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.32 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.33 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.34 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.35 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.36 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.37 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.38 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.39 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.4 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.40 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.41 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.42 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.43 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.44 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.45 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.46 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.47 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.48 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.49 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.5 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.50 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.51 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.52 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.53 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.54 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.55 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.6 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.7 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.8 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.9 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • teamtnt/laravel-scout-tntsearch-driver v3.0.4 requires teamtnt/tntsearch 1.0.* -> satisfiable by teamtnt/tntsearch[v1.0.0, v1.0.1, v1.0.2, v1.0.3, v1.0.4, v1.0.5, v1.0.6, v1.0.7].
    • teamtnt/tntsearch v1.0.7 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.6 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.5 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.4 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.3 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.2 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.1 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.0 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • Installation request for anomaly/streams-platform ~1.5.0 -> satisfiable by anomaly/streams-platform[v1.5.0, v1.5.1, v1.5.10, v1.5.11, v1.5.12, v1.5.13, v1.5.14, v1.5.15, v1.5.16, v1.5.17, v1.5.18, v1.5.19, v1.5.2, v1.5.20, v1.5.21, v1.5.22, v1.5.23, v1.5.24, v1.5.25, v1.5.26, v1.5.27, v1.5.28, v1.5.29, v1.5.3, v1.5.30, v1.5.31, v1.5.32, v1.5.33, v1.5.34, v1.5.35, v1.5.36, v1.5.37, v1.5.38, v1.5.39, v1.5.4, v1.5.40, v1.5.41, v1.5.42, v1.5.43, v1.5.44, v1.5.45, v1.5.46, v1.5.47, v1.5.48, v1.5.49, v1.5.5, v1.5.50, v1.5.51, v1.5.52, v1.5.53, v1.5.54, v1.5.55, v1.5.6, v1.5.7, v1.5.8, v1.5.9].

    To enable extensions, verify that they are enabled in your .ini files:

    • C:\xampp\php\php.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

Answer

wakanda - 2 months ago

You need enable "sqlite3" extensions in your version of PHP.

wakanda - 2 months ago

You need enable "sqlite3" extensions in your version of PHP.

dexter1 - 2 months ago

How do I do that?

dexter1 - 2 months ago

Fixed this part