Fresh Install
Created 1 week ago by adyoi

d:\localhost\laravel>composer create-project pyrocms/pyrocms Installing pyrocms/pyrocms (v3.6.4)

  • Installing pyrocms/pyrocms (v3.6.4): Downloading (100%) Created project in D:\localhost\laravel\pyrocms Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

    Problem 1

    • anomaly/streams-platform v1.5.0 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.1 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.10 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.11 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.12 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.13 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.14 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.15 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.16 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.17 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.18 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.19 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.2 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.20 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.21 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.22 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.23 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.24 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.25 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.26 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.27 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.28 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.29 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.3 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.30 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.31 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.32 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.33 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.34 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.35 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.36 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.37 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.38 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.39 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.4 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.40 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.41 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.42 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.43 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.44 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.45 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.46 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.47 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.48 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.49 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.5 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.50 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.51 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.52 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.53 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.54 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.55 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.56 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.57 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.58 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.59 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.6 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.60 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.61 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.62 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.63 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.64 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.65 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.66 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.67 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.68 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.69 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.7 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.70 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.71 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.72 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.73 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.74 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.75 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.76 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.77 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.78 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.8 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • anomaly/streams-platform v1.5.9 requires teamtnt/laravel-scout-tntsearch-driver 3.0.4 -> satisfiable by teamtnt/laravel-scout-tntsearch-driver[v3.0.4].
    • teamtnt/laravel-scout-tntsearch-driver v3.0.4 requires teamtnt/tntsearch 1.0.* -> satisfiable by teamtnt/tntsearch[v1.0.0, v1.0.1, v1.0.2, v1.0.3, v1.0.4, v1.0.5, v1.0.6, v1.0.7].
    • teamtnt/tntsearch v1.0.7 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.6 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.5 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.4 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.3 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.2 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.1 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • teamtnt/tntsearch v1.0.0 requires ext-sqlite3 * -> the requested PHP extension sqlite3 is missing from your system.
    • Installation request for anomaly/streams-platform ~1.5.0 -> satisfiable by anomaly/streams-platform[v1.5.0, v1.5.1, v1.5.10, v1.5.11, v1.5.12, v1.5.13, v1.5.14, v1.5.15, v1.5.16, v1.5.17, v1.5.18, v1.5.19, v1.5.2, v1.5.20, v1.5.21, v1.5.22, v1.5.23, v1.5.24, v1.5.25, v1.5.26, v1.5.27, v1.5.28, v1.5.29, v1.5.3, v1.5.30, v1.5.31, v1.5.32, v1.5.33, v1.5.34, v1.5.35, v1.5.36, v1.5.37, v1.5.38, v1.5.39, v1.5.4, v1.5.40, v1.5.41, v1.5.42, v1.5.43, v1.5.44, v1.5.45, v1.5.46, v1.5.47, v1.5.48, v1.5.49, v1.5.5, v1.5.50, v1.5.51, v1.5.52, v1.5.53, v1.5.54, v1.5.55, v1.5.56, v1.5.57, v1.5.58, v1.5.59, v1.5.6, v1.5.60, v1.5.61, v1.5.62, v1.5.63, v1.5.64, v1.5.65, v1.5.66, v1.5.67, v1.5.68, v1.5.69, v1.5.7, v1.5.70, v1.5.71, v1.5.72, v1.5.73, v1.5.74, v1.5.75, v1.5.76, v1.5.77, v1.5.78, v1.5.8, v1.5.9].

    To enable extensions, verify that they are enabled in your .ini files:

    • C:\xampp\php\php.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

d:\localhost\laravel>

ryanthompson  —  4 days ago Best Answer

Looks like your environment is missing the ext-sqlite3 as described by the output there :-/

Install and enable the extension and you should be set!

adyoi  —  1 week ago

installer: http://example.com/installer (NOT FOUND)

adyoi  —  1 week ago

d:\localhost\laravel\pyrocms>php artisan install The MIT License (MIT) Copyright (c) 2018 AnomalyLabs, Inc. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Do you agree to the provided license and terms of service? (yes/no) [no]:

yes

What database driver would you like to use? [mysql, pgsql, sqlite, sqlsrv] [mysql]:

mysql

What is the hostname of your database? [localhost]:

What is the name of your database?:

pyrocms

Enter the username for your database connection [root]:

Enter the password for your database connection:

[ERROR] A value is required.

Enter the password for your database connection:

''

Enter the name of your application [Default]:

myapp

Enter the reference slug for your application [default]:

Enter the primary domain for your application [localhost]:

Enter the desired username for the admin user [admin]:

Enter the desired email for the admin user:

admin@admin.com

Enter the desired password for the admin user:

admin123

Enter the default locale [en]:

Enter the default timezone [UTC]:

Asia/Jakarta

1/57 Running core migrations.

ryanthompson  —  4 days ago Best Answer

Looks like your environment is missing the ext-sqlite3 as described by the output there :-/

Install and enable the extension and you should be set!