junex03 - 2 weeks ago

Hi, I'm getting an error when installing pyrocms:

C:\test_project>composer global require "pyrocms/installer" Changed current directory to C:/Users/Sarah/AppData/Roaming/Composer Using version ^1.3 for pyrocms/installer ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Conclusion: don't install pyrocms/installer v1.3.9
  • Conclusion: don't install pyrocms/installer v1.3.8
  • Conclusion: don't install pyrocms/installer v1.3.7
  • Conclusion: don't install pyrocms/installer v1.3.6
  • Conclusion: don't install pyrocms/installer v1.3.5
  • Conclusion: don't install pyrocms/installer v1.3.4
  • Conclusion: don't install pyrocms/installer v1.3.3
  • Conclusion: don't install pyrocms/installer v1.3.2
  • Conclusion: don't install pyrocms/installer v1.3.1
  • Conclusion: remove symfony/console v4.1.6

Any help would be greatly appreciated as I am quite new with laravel, composer and of course pyrocms.

Thanks

ryanthompson - 2 weeks ago

What is your PHP environment look like? Apache? Might be a min-requirements thing.

junex03 - 2 weeks ago

It's good now, I reinstalled everything and installed all the stuff it required.

Thanks