lckamal - 1 year ago

I tried installing some Pre-Order modules which I have access rights. But I am not able to install them. Has someone installed them successfully? like: cart-module, products-module, api-module etc..

I have tried adding this on composer ```"repositories": [ { "type": "git", "url": "" } ]

also tried like this:
This is the error I get on composer update:
Some example from existing installation would be great.

thinkgraphical - 1 year ago

Think it got something to do with the repo's being private.

Don't know if it's the correct way but, this is how i do it:

  • download the module from github & place it in a 'preordered' folder in your project.
  • then add it to your composer.json as following:
    "require": {
        "emange/list-field_type": "dev-master"
    "repositories": [

ryanthompson - 1 year ago

I am actively (like last night / today) working on the API module as well. Store is pre-release.

Another good one in there is the Streams Module:

lckamal - 1 year ago

I Installed Streams module but even if namespace is already added the message still appears "To get started create your first namespace! Save". Its already in db also:

lckamal - 1 year ago

@thinkgraphical - The trick worked. Thanks