Issue in Admin Ajax Tables

srinivas214 - 1 month ago

Hi, We are trying to make the Table Builder to work in Ajax by setting $ajax = true in Table builder class but we are unable to make this work. Also tried the below code but not worked for me. public function index(ProductTableBuilder $table) { $table->setAjax(true); return $table->render(); }

Please any one help me to fix this issue.

Thanks in advance!

ryanthompson - 1 month ago

Can you confirm that this is the view being loaded: vendor/anomaly/streams-platform/resources/views/table/ajax.twig

srinivas214 - 1 month ago

Thanks @ryanthompson for reply!

Yes, This is loading from vendor/anomaly/streams-platform/resources/views/table/ajax.twig

We can only see the table with out any design and ajax not working in the table rendered.

ryanthompson - 1 month ago

Take a look at the ajax.js included.. that will help point you in the right direction I think. Something about frontend must be messing with it.

srinivas214 - 4 weeks ago

Hi @ryanthompson ,

There is no ajax.js being included in the page when $ajax = true in Table builder.

Instead i couldn't find any ajax.js file in pyrocms/vendor/anomaly/streams-platform/resources/js/table folder.

Please help me if there is any option or with an example to build the Ajax based table builder in pyrocms.

Thanks!

ryanthompson - 4 weeks ago

Hmm.. so I see. That's odd. I'll have to check up on this perhaps it got removed due to bugs? Ill look into it :-(