worthi - 2 months ago

I just installed Pyrocms and am running into a bunch of issues. The first problem has been installing addons to Pyrocms. I have tried doing this manually but on the addon page the manually uploaded extentions only show options for "view" (not the normal "uninstall" or "disable"). When I click into the addon they say uninstalled and status disabled. Any thoughts on how to get this working?

Second, I have been trying to use the file upload but receive a 404 error when uploading to the Images folder. This does not seem to happen with the document folder. Ideally I would like to get the s3 adapter working anyways so this may not be a big issue if I can get the addons working properly.

ryanthompson - 2 months ago

@worthi sorry to hear you've been having issues.

Firstly I would say unless your environment is setup a certain it's best to not use the addons module as an "installer" unfortunately it's currently a local only (disables on non-development environments). It's got some serious improvements in the pipeline as we work towards better OTA addon delivery but it's still in progress to being a robust manager.

For installing / downloading composer use require anomaly/api-module for example and then php artisan addon:install anomaly.module.api for example.

The 404 error is typically an NGINX / Apache thing where it's attempting to check if the file exists and the request is being treated as a physical file by the server. I've also got this patch in the roadmap more immediately as we run into this occasionally but here's a hint on how to fix it for NGINX: https://pyrocms.com/documentation/pyrocms/3.4/installation/server-configuration#nginx-example

More specifically this part:

location ~* \.(?:jpg|jpeg|gif|png|ico|gz|svg|svgz|ttf|otf|woff|eot|mp4|ogg|ogv|webm)$ {

        try_files $uri $uri/ /index.php?$query_string;

        access_log off;
        log_not_found off;
    }

I will make it a point to get that patched this week though.

worthi - 2 months ago

I appreciate the update. Does this mean wont be able to install addons on a live site? Sadly, if so, this will not work for my project at this time.

Is there a contact email to request cancelling pro plans?

frednwt - 2 months ago

I appreciate the update. Does this mean wont be able to install addons on a live site? Sadly, if so, this will not work for my project at this time.

Umm, Ryan gave you the method to install an addons on a live site. If for some reason you cannot use composer install you can also:

  1. Using FTP (or anyother way), upload your addon in /app/shared/{namepace}/{addonName}
  2. composer dump-autoload
  3. Then php artisan addon:install namespace.addon.name

OR

  1. Using the Addon Module, the Addon will now appear in "Downloaded" and "Install" will be available

The only thing not possible in live is only to use the "Download" button from the Addon Module. That why you need to do it manually.

worthi - 2 months ago

Thanks for the clarification, as I was slightly confused by Ryan's comment. To be clearer on my end, I have tried to upload the addons manually but cannot seem to get them enabled. I keep running into an error when running "php artisan addon:install namespace.addon.name". I keep receiving an error "Could not open file: artisan". I had this same issue during installation which required different means in order to get Pyrocms installed.

ryanthompson - 2 months ago

@worthi artisan is only available within the root directory of your project. Which is here for example in the repo: https://github.com/pyrocms/pyrocms

Note the artisan file. That's where you want to be when you try and run that command. Hope this helps!

ryanthompson - 2 months ago

You can definitely run installs on live sites! After I have my sites installed I also use Envoy to run updates n stuff too. Here is an example:

@servers(['web' => 'qcselfstorage@OUR_IP_ADDRESS -p OUR_PORT'])

@task('update', ['on' => 'web'])
cd /home/qcselfstorage/public_html
composer update -o
@endtask

@task('push', ['on' => 'web'])
cd /home/qcselfstorage/public_html
git pull
@endtask

@task('compile', ['on' => 'web'])
cd /home/qcselfstorage/public_html
php artisan asset:clear
php artisan twig:clean
php artisan streams:compile
@endtask

Also for cancellation just email me. But I think this is just a little hiccup :-/

worthi - 2 months ago

Well i've gotten close but still hitting a roadblock when trying to install the s3 adapter via composer. Here is the error I get: " [InvalidArgumentException] Could not find a matching version of package anomaly/s3_adapter-extension. Check the package sp elling, your version constraint and that the package is available in a stability which matches your minimum-stability (stable). "

When attempting to do the install manually using artisan command I get the following error: "The [anomaly.extension.s3_adapter] could not be found."

I feel like i'm almost there but just must be missing something.