Post Module Publish Date stuck in UTC

sumentuten - 7 months ago

I have entered UTC as time format on the installer when I installed Pyro. Then I later changed it to Europe/Sofia, but whenever I publish a Post its always set on the default UTC time zone. Is there a way to reset this to any timezone I set at the config?

ryanthompson - 7 months ago

Your settings reflect the Europe/Sofia value? But Posts do not you say? Just want to understand correctly before I dig in - sounds like a config is getting stuck in Posts.

sumentuten - 7 months ago

Yes, my settings reflect Europe/Sofia, but when I create a new post the publish time on the bottom of the form says it's UTC.

ryanthompson - 7 months ago

In your database's streams_fields table find the publish_at config value in the posts namespace. It should be a:0:{}

sumentuten - 7 months ago

It is set to a:0:{}. I echoed the timestamp value to see if it returns the correct timezone may only the input label is stuck, but it returned a wrong timestamp.

ryanthompson - 7 months ago

Can you go to settings and verify / save the form again that the TZ is correct? Or verify in the DB that the value in settings is correct.

sumentuten - 7 months ago

Resaved the timezone setting to Asia/Manila then checked the DB Table default_settings_settings, and Asia/Manila is the value for the streams::timezone key. But still UTC when I create a post.

sumentuten - 7 months ago

I got it. I was modifying the Settings Module values for the time format and timezone but the Post Module is using the Preferences Module values for the timezone and format.

PS: What is the difference between these two settings page in terms of time formats and timezones?

ryanthompson - 7 months ago

Aha.. preferences are user specific while settings are global. I will make an issue to fix this it should use preferences and fallback to settings.