Posts and Languages

mazedlx - 11 months ago

So, pages can be multilanguage, and can be accessed like site.dev/en/welcome and site.dev/de/welcome. But when I add a new post, the post title and summary can be saved in multiple languages, but not the content. Am I doing anything wrong?

Answer

mazedlx - 11 months ago

@huglester thank you, but I've found an easier way:

Control Panel > Posts > Types > Assignments for the desired post type (my case: default) > Content (the translatable Field) > Edit > Turn on Is this field translatable?

ryanthompson - 11 months ago

I think the content that's seeded is not multilingual (same used to be for pages). Feel free to delete the field assignment and re-add as translatable.

If you want - make an issue prefixed [posts-module] that notes the change needed for the seeded content. I think that is a good idea for out of the box behavior (translatable vs not).

mazedlx - 11 months ago

And how would I do that? Make a post translatable that is.

huglester - 11 months ago

Hello

go to: /admin/pages/fields there is a Content field type which was not trasnlate'able. you must remove it and create new one - translate'able.

that would solve your issue

mazedlx - 11 months ago

@huglester thank you, but I've found an easier way:

Control Panel > Posts > Types > Assignments for the desired post type (my case: default) > Content (the translatable Field) > Edit > Turn on Is this field translatable?