pdring - 8 months ago

Hi, I just installed a fresh copy of PyroCMS 3.4 and get the following error if I try to access the Addons folder via the control panel: file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure The highlighted line on the error page is $config->get("anomaly.module.addons::repository.{$this->repository}.url") . '/packages.json' I have another site running locally using MAMP on the same version of PHP (7.0.8) which has been updated and runs fine. No idea why this error occurs. Thanks.

ryanthompson - 8 months ago

Both of these sites are on the exact same MAMP installation/environment?

Clear cache on your other install and reload it's addons module in the CP. Any errors? When this happened to me (a while ago) I had to update MAMP.

fryiee - 8 months ago

Do you have the openSSL extension installed for PHP? https://pyrocms.com/documentation/pyrocms/3.4/installation/server-requirements

pdring - 8 months ago

If I run "composer show -p", I see "ext-openssl 7.1.7 The openssl PHP extension". If I run "php -m", I see "openssl".

pdring - 8 months ago

I'm running MAMP Pro 3.5.2 and both PyroCMS sites are on PHP 7.0.8

pdring - 8 months ago

I'll try the cache solution, thanks.

pdring - 7 months ago

This still isn't working. I tried a fresh install, still cleared the cache and I keep getting this error when I try to click on addons. I'm currently on MAMP 3.5.2. To which version did you have to update? I'll see if I can get this working on an actual web server.

ryanthompson - 7 months ago

Hi @pdring - I think this is an outdated issue with your OpenSSL extension? I ran into this before and had to update my system a bit..

You can also install the older version of the addons module by changing the requirement in your composer.json file.

Hope this helps!

PS disregard my email - I didn't see this (it was the next message :-P)

pdring - 7 months ago

I downgraded to anomaly/addons-module": "~2.1.0" and it all works now :)