[theme] - Asset parse doesn't parse while publishing to public/app...

lckamal - 3 months ago

I have this asset on metadata:

{{ asset_add("theme.css", "theme::css/font-awesome.min.css", ["parse"]) }}
{{ asset_add("theme.css", "theme::css/bootstrap.min.css", ["parse"]) }}
{{ asset_add("theme.css", "theme::css/jquery.bxslider.css", ["parse"]) }}
{{ asset_add("theme.css", "theme::css/normalize.min.css") }}
{{ asset_add("theme.css", "theme::css/bootstrap-select.min.css") }}
{{ asset_add("theme.css", "theme::css/style.css", ["parse"]) }}
{{ asset_add("theme.css", "theme::css/responsive.css") }}
{{ asset_style("theme.css") }}

parse is not working. in compiled css also I can see asset_path("theme::fonts/...") etc. in public/app/default/assets/public/theme.css

jolusadev - 3 months ago

Just put your fonts into public/fonts folder and it'll work

lckamal - 3 months ago

yeah, that can be a workaround but in other cases parsing is also required. works in other project but didn’t work in this one which is a fresh install made today.

lckamal - 3 months ago

It was because it didn't give error if asset is not found in theme path. so the error is supressed in css file and we don't know what is going wrong. to fix this just pasted css in metadata and able to see error msg.

ryanthompson - 3 months ago

It might be errorring out: https://github.com/anomalylabs/streams-platform/blob/1.2/src/Asset/Asset.php#L518

Try putting something in there.. need to pry enable that for debug mode huh?