Blog posts suddenly not working anymore

fuero - 1 month ago

Hi there,

So.. a while ago I've made this website for a client running on PyroCMS 2.2.5. All things nice and well and I didn't consider updating to v3 since everything was running nicely, until now.

For some reason the blog posts aren't showing anymore. I don't know if this is a PHP error or something else, but I just can't figure it out. I've used the following code but it everything between the {{ blog:posts }} - {{ /blog:posts }} isn't showing.

{{ blog:posts category="cat1|cat2" }}

{{ thumbnail.thumb.img }}

{{ title }}

{{ intro }}

Lees verder

{{ /blog:posts }}

Anyone who can help me? Or is it game-over for this website?

Regards, Chris

edster - 1 month ago

Check your host didn't update the PHP version, I had the same problem and old 2.2 sites were falling apart.

ryanthompson - 1 month ago

It would be a good idea to disable php strict mode - I recently ran into an issue with this on a system that automatically updates minor patches: https://www.google.com/search?q=disable+php+strict+standards&oq=disable+php+stri&aqs=chrome.1.69i57j0l5.4646j0j7&sourceid=chrome&ie=UTF-8

fuero - 1 month ago

Thanks! I've tried some stuff found on Google but unfortunately nothing worked. Any other suggestions?

b1gw0rm - 1 month ago

I checked a 2.2 version of Pyro and it uses {{ posts }} ... {{ /posts }} on a working blog page. Give that a try just for fun?

fuero - 1 month ago

Unfortunately still not working. Seems like everything inside {{ blog:posts }} ... {{ /blog:posts }} or {{ posts }} ... {{ /posts }} won't show. Is there a way to use pure PHP instead of lex tags @ryanthompson ?

ryanthompson - 1 month ago

Sounds like there's a PHP conflict going on - what's the server? cPanel? What about logs? Are they not reflecting anything that you can tell? The rest of the view works just not rendering posts I assume?

If you're at all considering updating to 3 - mostly likely will be an easy process for you (just sayin :-P)