Installation ok - but it's not working at all...

marvel - 4 months ago

Just tried to install Pyro...

The main webpage

Returns 500 - It's broken. In the log I see this:

[2017-04-25 12:02:39] local.ERROR: Twig_Error_Syntax: Unknown "cart" function in "theme::partials/navigation" at line 35. in /home/caw/webpage/vendor/twig/twig/lib/Twig/ExpressionParser.php:665

The admin panel

Just slides away - it does not matter what name/password I enter - I always end up with a gray screen with the flame icon. Strange is that it does not even create a network connection after clicking "Login". There's also no log message in the browser. There's also no message in the server log (which is not surprising without the connection)

piterden - 4 months ago

What if you try to install it with artisan?

marvel - 4 months ago

Same. I've tried both: The Installer webpage and php artisan install. Answered all questions. Installation delivers no error. Database tables are all created. .env is updated.

ryanthompson - 4 months ago

Nope my bad - fixing..

marvel - 4 months ago

Thanks - it works now.

Just wondering: How do your release checks look like? Are there automated tests / CI? I would really like to avoid going into production with Pyro and ending up with a broken page after using composer upgrade...

steve - 4 months ago

Installed pyro with pyro new and that worked. Followed the video reviewing the starter theme. Following the video about how you setup for a new client by creating a new theme as example.theme.demo, copying github.com/anomallylabs/bootstrap4-theme and replacing the resources folder, going into the administration area and choosing this theme. After attempting to view the theme I receive a 500 error as: Symfony \ Component \ Debug \ Exception \ FatalErrorException (E_UNKNOWN) Method Anomaly\Streams\Platform\Image\Image::__toString() must not throw an exception, caught ErrorException: filemtime(): stat failed for /Users/stevewarner/dev/silly/public/app/default/assets//187057d83e4ff51f25cba86bd0afdaad.