[country-field_type] Sorting is wrong and ignoring top_options
Created 2 years ago by emergingdzns

I've got a country field type and it's not working right. In the field config i have "top_options" set to the following but it's ignoring it.

"top_options"   => '["AR","BE","BR","CA","CL","CO","CZ","DK","EC","FR","DE","HU","IE","IT","LV","LU","MX",
                                 "NL","NZ","PL","SCT","SK","ES","CH","SE","GB","US","VE"]',

Also, the drop down has the countries sorted by I believe country code and not by name. Is that how it's supposed to be?

ryanthompson  —  2 years ago

I think the config is sorted by code which is what is uses to load the options by default. Open an issue on that top options - I just confirmed here and I can fix that quick.

emergingdzns  —  2 years ago

Ok I created a new issue (got them mixed up but corrected). So is there no way to tell it to sort by label? It's extremely annoying to see United Arab Emerites as the second option after Argentina (along with Spain being in E section etc).

ryanthompson  —  2 years ago

Ill have it sort by label - cause that's what makes sense to the end user.

vargvinter  —  1 year ago

Does it work? I have newest version of country field type (2.3.2) and the problem still occurs.

https://ibb.co/f04hH6