zvineyard - 4 weeks ago

For a couple of weeks now, whenever I try to require a new package with Composer (I was trying to install Passport), I get a minimum-stability error from Composer on the anomaly/streams-platform:

Problem 1
    - The requested package anomaly/streams-platform ~1.2.0 is satisfiable by anomaly/streams-platform[1.2.x-dev, v1.2.0, v1.2.1, v1.2.10, v1.2.100, v1.2.101, v1.2.102, v1.2.103, v1.2.104, v1.2.105, v1.2.106, v1.2.107, v1.2.108, v1.2.109, v1.2.11, v1.2.110, v1.2.111, v1.2.112, v1.2.113, v1.2.114, v1.2.115, v1.2.116, v1.2.117, v1.2.118, v1.2.119, v1.2.12, v1.2.120, v1.2.121, v1.2.122, v1.2.123, v1.2.124, v1.2.125, v1.2.126, v1.2.127, v1.2.128, v1.2.129, v1.2.13, v1.2.130, v1.2.131, v1.2.132, v1.2.133, v1.2.134, v1.2.135, v1.2.136, v1.2.137, v1.2.138, v1.2.139, v1.2.14, v1.2.140, v1.2.141, v1.2.142, v1.2.143, v1.2.144, v1.2.145, v1.2.146, v1.2.147, v1.2.148, v1.2.149, v1.2.15, v1.2.150, v1.2.151, v1.2.152, v1.2.153, v1.2.154, v1.2.155, v1.2.156, v1.2.157, v1.2.158, v1.2.159, v1.2.16, v1.2.160, v1.2.161, v1.2.163, v1.2.164, v1.2.165, v1.2.166, v1.2.167, v1.2.168, v1.2.169, v1.2.17, v1.2.170, v1.2.171, v1.2.172, v1.2.173, v1.2.174, v1.2.175, v1.2.176, v1.2.177, v1.2.178, v1.2.179, v1.2.18, v1.2.180, v1.2.181, v1.2.182, v1.2.183, v1.2.184, v1.2.185, v1.2.186, v1.2.187, v1.2.188, v1.2.189, v1.2.19, v1.2.190, v1.2.191, v1.2.192, v1.2.193, v1.2.195, v1.2.196, v1.2.197, v1.2.198, v1.2.199, v1.2.2, v1.2.20, v1.2.200, v1.2.201, v1.2.202, v1.2.203, v1.2.204, v1.2.205, v1.2.206, v1.2.207, v1.2.208, v1.2.209, v1.2.21, v1.2.210, v1.2.211, v1.2.212, v1.2.213, v1.2.214, v1.2.215, v1.2.216, v1.2.217, v1.2.218, v1.2.219, v1.2.22, v1.2.220, v1.2.221, v1.2.222, v1.2.223, v1.2.224, v1.2.225, v1.2.226, v1.2.227, v1.2.228, v1.2.229, v1.2.23, v1.2.230, v1.2.231, v1.2.232, v1.2.233, v1.2.234, v1.2.235, v1.2.236, v1.2.237, v1.2.238, v1.2.239, v1.2.24, v1.2.240, v1.2.241, v1.2.242, v1.2.243, v1.2.244, v1.2.245, v1.2.246, v1.2.247, v1.2.248, v1.2.249, v1.2.25, v1.2.250, v1.2.251, v1.2.252, v1.2.253, v1.2.254, v1.2.255, v1.2.256, v1.2.257, v1.2.258, v1.2.259, v1.2.26, v1.2.260, v1.2.261, v1.2.262, v1.2.263, v1.2.264, v1.2.265, v1.2.266, v1.2.267, v1.2.268, v1.2.269, v1.2.27, v1.2.270, v1.2.271, v1.2.272, v1.2.273, v1.2.274, v1.2.275, v1.2.276, v1.2.277, v1.2.278, v1.2.279, v1.2.28, v1.2.280, v1.2.281, v1.2.282, v1.2.283, v1.2.284, v1.2.285, v1.2.286, v1.2.287, v1.2.288, v1.2.289, v1.2.29, v1.2.290, v1.2.291, v1.2.292, v1.2.293, v1.2.294, v1.2.295, v1.2.296, v1.2.297, v1.2.298, v1.2.299, v1.2.3, v1.2.30, v1.2.300, v1.2.301, v1.2.302, v1.2.303, v1.2.304, v1.2.305, v1.2.306, v1.2.307, v1.2.308, v1.2.309, v1.2.31, v1.2.310, v1.2.311, v1.2.312, v1.2.313, v1.2.314, v1.2.315, v1.2.316, v1.2.317, v1.2.318, v1.2.319, v1.2.32, v1.2.320, v1.2.321, v1.2.322, v1.2.323, v1.2.324, v1.2.325, v1.2.326, v1.2.327, v1.2.328, v1.2.329, v1.2.33, v1.2.330, v1.2.331, v1.2.332, v1.2.333, v1.2.334, v1.2.335, v1.2.336, v1.2.337, v1.2.338, v1.2.339, v1.2.34, v1.2.340, v1.2.341, v1.2.342, v1.2.343, v1.2.344, v1.2.345, v1.2.346, v1.2.347, v1.2.348, v1.2.349, v1.2.35, v1.2.350, v1.2.351, v1.2.352, v1.2.353, v1.2.354, v1.2.355, v1.2.356, v1.2.357, v1.2.358, v1.2.359, v1.2.36, v1.2.360, v1.2.361, v1.2.362, v1.2.363, v1.2.364, v1.2.365, v1.2.366, v1.2.367, v1.2.368, v1.2.369, v1.2.37, v1.2.370, v1.2.371, v1.2.372, v1.2.373, v1.2.374, v1.2.375, v1.2.376, v1.2.377, v1.2.378, v1.2.379, v1.2.38, v1.2.380, v1.2.381, v1.2.382, v1.2.383, v1.2.384, v1.2.385, v1.2.386, v1.2.387, v1.2.388, v1.2.389, v1.2.39, v1.2.390, v1.2.391, v1.2.392, v1.2.393, v1.2.394, v1.2.395, v1.2.396, v1.2.397, v1.2.398, v1.2.399, v1.2.4, v1.2.40, v1.2.400, v1.2.401, v1.2.402, v1.2.403, v1.2.404, v1.2.405, v1.2.406, v1.2.407, v1.2.408, v1.2.409, v1.2.41, v1.2.410, v1.2.411, v1.2.412, v1.2.413, v1.2.42, v1.2.43, v1.2.44, v1.2.45, v1.2.46, v1.2.47, v1.2.48, v1.2.49, v1.2.5, v1.2.50, v1.2.51, v1.2.52, v1.2.53, v1.2.54, v1.2.55, v1.2.56, v1.2.57, v1.2.58, v1.2.59, v1.2.6, v1.2.60, v1.2.61, v1.2.62, v1.2.63, v1.2.64, v1.2.65, v1.2.66, v1.2.67, v1.2.68, v1.2.69, v1.2.7, v1.2.70, v1.2.71, v1.2.72, v1.2.73, v1.2.74, v1.2.75, v1.2.76, v1.2.77, v1.2.78, v1.2.79, v1.2.8, v1.2.80, v1.2.81, v1.2.82, v1.2.83, v1.2.84, v1.2.85, v1.2.86, v1.2.87, v1.2.88, v1.2.89, v1.2.9, v1.2.90, v1.2.91, v1.2.92, v1.2.93, v1.2.94, v1.2.95, v1.2.96, v1.2.97, v1.2.98, v1.2.99] but these conflict with your requirements or minimum-stability.

I've tried adjusting the minimum-stability, but can't seem to pin this one down. Any ideas?

edster - 4 weeks ago

post your composer.json.

Mine is set to "anomaly/streams-platform": "~1.3.0", are you up to date on this site? Sounds like it needs to be upgraded.

ryanthompson - 4 weeks ago

Ya probably a conflict between the two packages. We've been on 1.3 for a while now. I would strongly encourage upgrading if you need to as well: https://pyrocms.com/help/developer-tools/cheatsheets/upgrading

zvineyard - 4 weeks ago

Mine is also set to "anomaly/streams-platform": "~1.3.0". The site I'm trying to update is a PyroCMS 3.4 install from last week. Any other ideas?

ryanthompson - 4 weeks ago

What is the output of this CLI command:

composer why anomaly/streams-platform

zvineyard - 4 weeks ago

Thank you for teaching me how to do that! Here's what that kicked back:

anomaly/boolean-field_type      v2.3.7      requires  anomaly/streams-platform (^1.2)
anomaly/checkboxes-field_type   v2.3.1      requires  anomaly/streams-platform (^1.2)
anomaly/colorpicker-field_type  v2.2.1      requires  anomaly/streams-platform (^1.2)
anomaly/country-field_type      v2.3.2      requires  anomaly/streams-platform (^1.2)
anomaly/decimal-field_type      v2.1.11     requires  anomaly/streams-platform (^1.2)
anomaly/editor-field_type       v2.3.3      requires  anomaly/streams-platform (~1.3.0)
anomaly/files-module            v2.4.1      requires  anomaly/streams-platform (^1.3.0)
anomaly/installer-module        v2.3.1      requires  anomaly/streams-platform (~1.3.0)
anomaly/markdown-field_type     v2.3.2      requires  anomaly/streams-platform (^1.3.0)
anomaly/pages-module            v2.3.2      requires  anomaly/streams-platform (~1.3.0)
anomaly/repeater-field_type     v1.3.2      requires  anomaly/streams-platform (~1.3.0)
anomaly/slider-field_type       v3.0.4      requires  anomaly/streams-platform (^1.2)
anomaly/tags-field_type         v2.3.0      requires  anomaly/streams-platform (^1.2.0)
anomaly/text-field_type         v2.2.2      requires  anomaly/streams-platform (^1.2)
anomaly/url-field_type          v2.2.9      requires  anomaly/streams-platform (~1.3.0)
anomaly/users-module            v2.4.12     requires  anomaly/streams-platform (^1.2)
anomaly/wysiwyg-field_type      v2.2.27     requires  anomaly/streams-platform (~1.3.0)
pyrocms/pyrocms                 dev-master  requires  anomaly/streams-platform (~1.3.0)

zvineyard - 4 weeks ago

OK, I just figured it out. I had accidentally copied in an old module into my addons folder that was calling for anomaly/streams-platform 1.2.0. Everything is back to normal!