robin - 4 months ago

I am having trouble loading the geocoder map, as you can see the placeholder beneath the empty area works with the input field, but the map isn't showing up: https://i.imgur.com/eFqT61c.png

This is happening in 2 different projects.

I am with both projects on streams-platform v1.3.133 and geocoder-field_type v1.1.40.

Not long ago it worked correctly on one of my (older) projects. Do I have to downgrade my geocoder-field_type or do I have more options to fix this?

Answer

ryanthompson - 4 months ago

OK.. now it's fixed. v1.1.43 - I ended up just display:none; on the map instead for the option that was added and causing issues.

ryanthompson - 4 months ago

Can you inspect your dom in that big whitespace? Any JS errors? Is the map initiated or is the placeholder just empty. An option was recently made to allow not showing the map but it's on by default and the placeholder would not be there if it was disabled.

ryanthompson - 4 months ago

Just fixed this https://github.com/anomalylabs/geocoder-field_type/commit/6385566a1314b001978106bc78521e09af617bb5

Give it a few minutes for the SATIS to build out and you should be good to go. Sorry about that!

robin - 4 months ago

Thanks for the quick update! Just updated to v1.40.1 - Map is back, but the pin doesn't relocate itself to the given input. See the result: https://i.imgur.com/aDEUIUv.png

ryanthompson - 4 months ago

Bah humbug! Just pushed the fix and SATIS is building right now.

ryanthompson - 4 months ago

Thank you for your patience and the heads up!

ryanthompson - 4 months ago

Oop - one moment.. One more thing to fix.

ryanthompson - 4 months ago

OK.. now it's fixed. v1.1.43 - I ended up just display:none; on the map instead for the option that was added and causing issues.

robin - 4 months ago

It works now, thanks again for your update. The map in the admin is not visible anymore indeed, but at least in the front-end it works now :)

ryanthompson - 4 months ago

Arg - you can tell I was frazzled yesterday. Default was false for testing. I've corrected my error (the last one for a while I hope).